AjaxDropdownInfo issue on a new project

Jul 5, 2011 at 3:58 PM

Hi,

I am trying to use Awesome on a new MVC3 project. I created a page with an Ajaxdropdown and it throws the following error:

\Shared\Awesome\AjaxDropdown.ascx(10): error CS1061: 'Omu.Awesome.Mvc.Helpers.AjaxDropdownInfo' does not contain a definition for 'Area' and no extension method 'Area' accepting a first argument of type 'Omu.Awesome.Mvc.Helpers.AjaxDropdownInfo' could be found (are you missing a using directive or an assembly reference?). I already have Omu.Awesome.Mvc.Helpers and Omu.Awesome.Core in my web.config.

What did I miss?

Regards

Coordinator
Jul 5, 2011 at 5:19 PM

probably your using the dlls from an older version

Jul 6, 2011 at 8:52 AM

I'm using version v1.9.0.0 of both Omu.Awesome.Core.dll and Omu.Awesome.Mvc.dll.

Coordinator
Jul 6, 2011 at 9:43 AM

try creating a new mvc project after use nuget to install awesome and see if it works

Jul 6, 2011 at 11:54 AM
Edited Jul 6, 2011 at 11:55 AM

I tried installing from both the official package source and from my local source and both failed. Here's the command and the error I got:

 

PM> install-package MvcProjectAwesome

Attempting to resolve dependency 'WebActivator (≥ 1.0.0.0)'.

Install-Package : File contains corrupted data.

At line:1 char:16+ install-package <<<<  MvcProjectAwesome   

+ CategoryInfo          : NotSpecified: (:) [Install-Package], FileFormatException   

+ FullyQualifiedErrorId : NuGetCmdletUnhandledException,NuGet.PowerShell.Commands.InstallPackageCommand

Please take note that I can install other packages. So I'm guessing it has something to do with the package file for MvcProjectAwesome.

Coordinator
Jul 6, 2011 at 12:19 PM

try updating your nuget/vs

I just tried installing and it works

here's my version of nuget: Package Manager Console Host Version 1.3.20419.9005

Jul 6, 2011 at 12:23 PM

I just updated before installing Awesome. Here's mine: 1.4.20609.9012

Coordinator
Jul 6, 2011 at 1:06 PM

ok, I've also updated nuget, here's my console:

Package Manager Console Host Version 1.4.20609.9012

Type 'get-help NuGet' to see all available NuGet commands.

PM> Install-Package mvcprojectawesome
Attempting to resolve dependency 'WebActivator (&#8805; 1.0.0.0)'.
Successfully installed 'WebActivator 1.0.0.0'.
Successfully installed 'MvcProjectAwesome 1.9'.
Successfully added 'WebActivator 1.0.0.0' to MvcApplication7.
Successfully added 'MvcProjectAwesome 1.9' to MvcApplication7.
I'm on Windows 7 VS2010 Ultimate Version 10.0.30319.341 .NET 4 MVC 3

Jul 6, 2011 at 1:40 PM
Edited Jul 6, 2011 at 1:43 PM

I am on Windows Vista VS2010 Ultimate 10.0.30319.1. 

I've tried installing a number of packages from the NuGet feed and was able to install them successfully. But it is only with Awesome that the install failed. Is there something special that I should do? Or maybe the package for Awesome is not updated?

Coordinator
Jul 6, 2011 at 2:04 PM

delete everything from %localappdata%\NuGet\ and try again

Jul 6, 2011 at 2:11 PM

I have tried that too based on some suggestions I found through googling.

This may contribute to the issue, just noticed it now, after I restarted my VS and opened the Package Manager console I got the ff:

Each package is licensed to you by its owner. Microsoft is not responsible for, nor does it grant any licenses to, third-party packages. Some packages may include dependencies which are governed by additional licenses. Follow the package source (feed) URL to determine any dependencies.

Package Manager Console Host Version 1.4.20609.9012

Type 'get-help NuGet' to see all available NuGet commands.

File contains corrupted data.

PM> install-package mvcprojectawesome

I am just wondering why others would install though.

Jul 7, 2011 at 7:28 AM

The problem was with the folder where I placed the new project. There is something in that folder that causes the "File contains corrupted data." on start-up of VS. I created a new project on a clean folder and the error message is gone. Once it did, the install-package succeeded as well. And I can now use the Awesome project on a completely new MVC 3 project. 

It is clear though that there is a bug with NuGet. It allowed me to install some packages and not Awesome and that was when all the packages came from the same source.

Thanks o!

Coordinator
Jul 7, 2011 at 7:58 AM

good job !!!